Garmaine Staff asked 2 years ago

I've been struggling to get my Eclipse working on my mac, I have 64 bit java, and my teacher tried to help me by giving me a download for a Mac Java JDK. At this point I feel like I've tried everything.

Here's what my eclipse.ini looks like:

--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.700.v20180518-1200
-product
org.eclipse.epp.package.java.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
-vm
/Library/Java/JavaVirtualMachines/jdk.1.6.0.jdk/Contents/Home/bin
-vmargs
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.6
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms256m
-Xmx512m
--add-modules=ALL-SYSTEM
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts

If you know any errors in my .ini file help would be much appreciated. (All I changed in my file was adding in -vm > /Library/… > -vmargs)